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MPLAB® IDE v6.xx
クィックスタート

クィックスタート

はじめに

本書は MPLAB® IDE バージョン 6.1x のインストールからデバックや PICmicro® 
MCU に書き込む方法までの概要を説明します。デバッグ機能についてはサンプル
コードを使います。それらに関連する機能についても説明します。 

概要

本書の最初の章では MPLAB IDE をパソコンにインストールする方法について説明し
ます。 次の章ではプロジェクトを作成して、MPLAB のデバッグ機能に慣れるための
ステップごとのチュートリアルです。MPLAB でビルドしたりテストしたりする方法
を覚えた後、最後の章では MPLAB でほかの開発ツールを使ったり、MPLAB をカス
タマイズします。

• MPLAB IDE を使う準備

• シンプルなプロジェクトのデバッグ

- プロジェクトの作成

- シミュレータの実行

- デバッグ

• 次に何を行う ?
- デバイスに書き込み

- シミュレータのオプション

- MPLAB ICD 2
- MPLAB IDE のオンライン・ヘルプ

- ワークスペースとプロジェクト

MPLAB IDE を使う準備

MPLAB IDE は Windows® 上で動作する PICmicro マイクロコントローラ (MCU) や
dsPIC™ デジタルシグナルコントローラ用の開発環境です。MPLAB IDE を使って次
のことを行えます :
• ビルドイン・エディタを使ってソース・コードを作る。

• いろいろな言語ツールを使って、ソース・コードをアセンブル、コンパイル、リ
ンクする。アセンブラ、リンカ、ライブラリアンは MPLAB IDE に入っていま
す。マイクロチップといくつかのサードパーティの C コンパイラもサポートし
ています。詳しくはリリースノートや Readme ファイルを参照してください。

• シミュレータやMPLAB ICE 2000エミュレータやMPLAB ICD 2インサーキット・
デバッガでプログラムの流れを見ながら論理的な動作をデバッグできる。サード
パーティのエミュレータもサポートするかもしれません。詳しくはリリースノー
トや Readme ファイルを参照してください。

• シミュレータやエミュレータを使ってタイミング測定ができる。

• WATCH ウィンドウで変数の内容を見る。
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• PICSTART® Plus や PRO MATE® II などを使ってデバイスにファームウエアを書
き込める。サードパーティのライタもサポートするかもしれません。詳しくはリ
リースノートや Readme ファイルを参照してください。

• MPLAB IDE オンライン・ヘルプで疑問点を調べることができます。 

サポートしているシステム

下記は MPLAB IDE が動作する最小システム構成です :
• PC 互換 Pentium® クラスのシステム

• Microsoft Windows 98, Windows 2000 SP2, Windows NT® SP6, Windows ME, 
Windows XP

• RAM 16 MB(32 MB 推奨 )
• ハードディスク空き 45MB
• Microsoft Internet Explorer 5.0 以降がインストールされていること

MPLAB IDE のインストールとアンインストール

MPLAB IDE をインストールするには :
• OS によっては、Administrator 権限でログインする必要があります。

• CD-ROM からのインストールの場合は、ドライブに CD-ROM を入れる。その後
はメニューにしたがってください。もしメニューが現れない場合は、エクスプ
ローラを使って MPLAB インストール実行ファイルを探して実行してください。

• マイクロチップの Web サイトからダウンロードした場合は、ダウンロードした
実行ファイルをダブルクリックしてインストールしてください。

MPLAB IDE をアンインストールするには :
• Start>Programs>Microchip MPLAB IDE メニューから UNWISE32 を選択するか

• MPLAB IDE をインストールしたフォルダの中の unwise32.exe を実行する。

MPLAB IDE を実行する

MPLAB IDEを実行開始するには Start>Programs>Microchip MPLAB IDE>MPLAB IDE
を選択します。 最初にスプラッシュ画面が表示され、その後に MPLAB IDE ディスク
トップが表示されます。

FIGURE 1: MPLAB IDE DESKTOP
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シンプルなプロジェクトのデバッグ

プロジェクトの作成

プロジェクトを使ってコード開発ができます。今回はビルドする全ファイルはプロ
ジェクトに入ります。一つのプロジェクトで使える言語ツールは一種類のみです。

プロジェクトは HEX ファイルを出力します。デバッグでも HEX ファイルはメモリ
にロードされて使われます。ほかにもソース・コードでのシンボル定義やメモリ上
のアドレスが入ったファイルが作られます。

プロジェクトの設定

まずワークスペースとプロジェクトの設定を確認します。今回はワークスペースを
意識する必要がない one-to-one project-workspace model を使います。本書の最終章
でワークスペースとプロジェクトについて説明します。

Configure>Settings ダイアログの Projects タブをクリックします。全項目をチェック
して、OK ボタンをクリックします。

FIGURE 2: SETTINGS: PROJECTS TAB
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デバイスの選択

MPLAB IDE で使うデバイスを選択します。 今回は PIC18F452 を使います。

1. Configure>Select Device を選択します。

FIGURE 3:  SELECT DEVICE DIALOG

2. Device の選択メニューから PIC18F452 を選択します。選択したデバイスをサ
ポートしているツールは緑、サポートしていないツールは赤、β 版などでサ
ポートしているツールは黄で表しています。

3. OK ボタンをクリックします。
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新規プロジェクトの作成

次のようにプロジェクトを新規作成できます。

1. Windows のエクスプローラを使って , プロジェクトを入れるフォルダを作りま
す ( たとえば C:\Myproj)。

2. MPLAB IDE の Project>New を選択して、New ダイアログを開きます (Figure 4).
3. プロジェクト名を入力します ( たとえば newproj)。
4. ステップ1で作ったフォルダをBrowseボタンを使うかタイプして入力します。

5. プロジェク名と場所が正しければ OK をクリックします。

FIGURE 4: NEW DIALOG

 

Note: ロングファイルネームを MPLAB IDE はサポートしていますが、サポー
トしていない言語ツールもあります。ソースファイル名やパスでロング
ファイルネームを使う場合は、言語ツールがサポートしていることを
チェックしてください。
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言語ツールの場所

Project> Set Language Tool Locations で Microchip ツールスイートの場所を確認しま
す。MPASM Assembler (mpasmwin.exe) をクリックして、Location of Selected Tool
テキストボックスで実行ファイルのパスが下図のようになっていなければ Browse
ボタンを使って mpasmwin.exe の場所を指定してください。

FIGURE 5: SET LANGUAGE TOOL LOCATION DIALOG

今回必要なのは MPASM アセンブラだけです。 他の言語ツールを使うプロジェクトの
場合は各言語ツールの場所を確認してください。

必要なツールの設定を確認後 OK ボタンをクリックします。

ツールスイートの設定

ソースコードを編集する前に言語ツールスイートを設定してください。

今回は Microchip ツールスイートを選択します :
1. Project>Set LanguageToolsuite を選択

2. Active Toolsuite に Microchip MPASM Toolsuite を選択します。 PICmicro の言語
ツールが Toolsuite Contents に表示されます。

3. OK ボタンをクリックします。

FIGURE 6: SELECT LANGUAGE TOOLSUITE DIALOG
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ソースコードの作成

MPLAB IDE のエディタを使ってコードを編集できます。

File>New を選択後、ワークスペースに編集ウィンドウが開きます。下記のサンプル
コードをタイプしたり、本書のファイルからコピーしてペーストしてください。

         title "PIC18F452 counting program"
         list p=18f452,f=inhx32
         #include <p18f452.inc>

COUNT     equ     0x00
DVAR      equ     0x01
DVAR2     equ     0x02

        org    00h             ;reset vector
        goto   Start

        org    1Ch
Start
        clrf   WREG            ;clear W register
        movwf  PORTC           ;clear PORTC
        movwf  TRISC           ;config PORTC as outputs
Init
        clrf   COUNT           ;clr count
IncCount
        incf   COUNT,F         ;increment count
        movf   COUNT,W         ;
        movwf  PORTC           ;display on port c

        call   Delay           ;wait
        goto   IncCount        ;loop

Delay
        movlw  0xFF            ;set delay loop
        movwf  DVAR2           ;
D0
        movwf  DVAR            ;reset inner loop
D1
        decfsz DVAR,F
        goto   D1

        decfsz DVAR2,F
        goto   D0
        return
        end

コードを入力し終わったら、File>Save を選択して cnt452.asmというファイル名で
プロジェクトフォルダに保存します。

保存した後、コードは色付けされて読みやすくなります。この色付け はカスタマイ
ズできます。詳しくは Help>MPLAB Editor Help を参照してください。
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ソースファイルの追加

作成したソースファイルをプロジェクトに追加します。

1. Project>Add Files to Project を選択します

FIGURE 7: SELECT INPUT FILE DIALOG

2. 作成したファイル (cnt452.asm) を選択します

3. Open ボタンをクリックします 

追加したファイルは Source Files の下に表示されます (Figure 8). もし Unclassifiable
の下に表示されたら、Project>Set Language Toolsuite の Active Toolsuite のところで
Microchip Toolsuite を選択しているかを確認してください。違っていたら、それを選
択して OK ボタンをクリックすれば Source Files の下に表示されるはずです。

FIGURE 8: PROJECT PANE (WINDOW)

Project>Save を選択してプロジェクトを保存します。

Note: 言語ツールによって名前の付け方が違います。たとえば、MPASM アセ
ンブラのソースファイルの場合は拡張子は .asm にしてください。ロン
グファイルネームをサポートしていない言語ツールもあります。 

TIP: 右クリックでもファイルを追加したり保存したりできます。プロジェク
トのパス名やファイル名の上で右クリックする場合と Source Files の上
で右クリックする場合はメニューが違います。
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プロジェクトのビルド

ソースファイルを追加したので、プロジェクトをビルドできます。ビルドすると選
択した言語ツールでソースコードがコンパイルされます。

プロジェクトをビルドするには Project>Build All を選択します。ソースファイルはエ
ラーなしでアセンブルされるはずです。

FIGURE 9:  OUTPUT WINDOW

エラーがあった場合は、下記の項目をチェックして再度ビルドしてください :
• Editor ウィンドウで編集したコードのタイプミスなどを確認します。Output ウィ
ンドウでアセンブラがエラーを報告している場合、そのエラーメッセージをダブ
ルクリックすれば、ソースコードウィンドウでエラーが報告された行が黄色の矢
印で示されます。

• MPASM アセンブラが選択されていることを確認します。Project>Set Language 
Tool Locationsを選択してMPASM Assembler (mpasmwin.exe)をクリックすると
その場所が表示されます。場所が正しければ Cancel ボタンをクリックします。 
正しくなければ修正して OK ボタンをクリックします。

ビルドしてエラーがなければ、言語ツールで生成されたデバッグファイル (*.cod ま
たは *.cof) がロードされます。それによってソースコードでデバッグしたり、Watch
ウィンドウで変数の内容を見れます。

プロジェクトの利点

ソースファイルが一つだけの場合では、プロジェクトは必要なさそうに見えます。
しかし、複数のソースファイルをアセンブル / コンパイルしてリンクする場合は、
プロジェクトがないと不便です。

また、Microchip ツールスイートでリンクすると、アセンブラだけを使う場合よりも
デバッグ用の情報を多く生成します。たとえば、ローカル変数についての情報など
もリンカは生成します。



MPLAB® IDE v6.xx Quick Start

DS51281B_J-page 10  2002 Microchip Technology Inc.

シミュレータの実行

プロジェクトをビルドしたら、考えたとおりに動作するかをデバッグ・ツールで確
認できます。今回はシミュレータを使います。

今回使っている PIC18F452 は MPLAB SIM シミュレータでサポートされています。
Debugger>Select Tool>MPLAB SIM で MPLAB SIM simulator を選択してください。

FIGURE 10: SELECT SIMULATOR AS THE DEBUGGER

MPLAB SIM を選択後、次の変化があるはずです :
1. ステータス・バー(MPLAB IDE ウィンドウの下辺)に MPLAB SIM と表示される

2. Debugger メニューの項目が増える

3. ツールバーにデバッグ用のアイコンが表示される

FIGURE 11: MPLAB IDE DESKTOP WITH MPLAB SIM AS DEBUGGER

このシミュレータはパソコン上で PICmicro MCU の命令の疑似動作を行うソフトウ
エアです。実行時間はリアルタイムではなく、パソコンの処理スピードやコードの
複雑さや OS のオーバーヘッドや他のタスクをいくつ実行しているかなどによって
変わります。しかし、実行時間を表示することはできます。

MPLAB ICE 2000 や MPLAB ICD 2 は外付けのハードウエア・ツールで、実際の PCB
上でリアルタイムにコードを実行できます。

TIP: カーソルをツールバーのアイコンの上に置くと、短い機能説明が表示さ
れます。

1

2

3
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デバッグ

準備ができたら、コードを実行させてデバッグできます。

コードの実行

まず Debugger>Reset を選択します。黄色の矢印が実行する行を指します。

FIGURE 12: SOURCE CODE WINDOW - AFTER RESET

コードを実行するには Debugger>Run を選択します。ステータスバーに Running…
と表示されます。

コードの実行を停止するには Debugger>Halt を選択します。黄色の矢印は停止した
行を指します。

Debugger>Step Into を選択すれば、シングルステップを実行できます。実行すると
矢印が指している行を実行後、矢印は次に実行される行へ移ります。

TIP: メニュー項目を選択する代わりに、ツールバーのアイコンやメニュー項
目の隣に書かれているショートカットキーも使えます。ステップを繰り
返す場合などで便利です。



MPLAB® IDE v6.xx Quick Start

DS51281B_J-page 12  2002 Microchip Technology Inc.

変数の内容表示

マウスのカーソルを変数の上に置けば、小さいウィンドウが現れて内容を表示しま
す。 

FIGURE 13: MOUSE OVER VARIABLE

Note: Microchip ツールスイートでは、この機能でローカル変数を表示できま
すが、ほかのツールスイートでは表示できないかもしれません。
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WATCH ウィンドウ 

ある変数の動きをしばらく見ていたい場合は、Watch ウィンドウが便利です。
Watch ウィンドウは View メニューのなかにあります。

1. View>Watch を選択して Watch ウィンドウを新規作成します。

2. SFR の選択メニューから PORTC を選択します。プルダウンアイコンを選択後
PORTC と入力したほうが早く入力できます。Add SFR ボタンをクリックして
Watch ウィンドウに追加します。

3. シンボルの選択メニューから COUNT を選択します。Add Symbol ボタンをク
リックして Watch ウィンドウに追加します。

4. シンボルの選択メニューから DVAR を選択します。Add Symbol ボタンをク
リックして Watch ウィンドウに追加します。

FIGURE 14:  WATCH WINDOW WITH SYMBOLS

Watch ウィンドウにシンボルが三つ入ったはずです。左からシンボルのファイルアド
レス、シンボル名、シンボルの内容が表示されます。コードをステップさせるとシ
ンボルの内容が変化します。

1. Debugger>Reset してリセットします。

2. 次の行になるまで Debugger>Step Into を選択、またはツールバーの同機能のア
イコンをクリックします :
incf   COUNT,F         ;increment count

3. ステップをもう 1 回実行すると COUNT の内容が 0 から 1 に変わります。

4. ステップをもう 2 回実行すると PORTC の内容が 0 から 1 に変わります。

5. ステップをもう 4回実行するとDVARの内容が FFに変わります。Watch ウィン
ドウのなかの値は、前回停止した状態から変化した場合は赤くなり、変化して
いない場合は黒くなります。
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FIGURE 15: STEPPING THROUGH CODE

ブレークポイントの設定

ある番地までコードを実行させて停止したい場合は、ブレークポイントが便利です。
ここではブレークポイントの簡単な使い方を説明します。Breakpoint ダイアログに
ついてはオンラインヘルプメニューで説明しています。

1. Debugger>Reset を選択してデバイスをリセットします。

2. 次の行をさがして、右クリックします :
movlw  0xFF            ;set delay loop

3. ポップアップメニューが表示されます。そのなかの Set Break Point を選択しま
す。その行にブレークポイントのマークが表示されます。

FIGURE 16: SOURCE CODE WINDOW - SET BREAKPOINT
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4. Debugger>Run を選択してコードを実行します。 実行後、設定したブレークポ
イントで停止するはずです。

FIGURE 17: SOURCE CODE WINDOW - BREAKPOINT HALT
 

トレース

トレースでコードの実行を記録できます。Debugger>Settings ダイアログの
Trace/Pins パネルでトレースをイネーブします。

FIGURE 18: SIMULATOR TRACE ENABLE

トレースのデータ収集する方法を決めるチェックボックスが二つあります。上の
チェックボックスがチェックされている場合は、シミュレータはコード実行中に停
止するまでデータ収集します。つまりブレークポイントや手動でコードを停止する
までデータを収集します。最後に実行したサイクルから数えて 8192 サイクル分の
データが収集されます。これでブレークポイントで停止するまでのコードの実行を
見ることができます。

下のチェックボックスもチェックされている場合は、8192 サイクルのデータを収集
したら実行が停止します。これは実行開始してからのコードの実行を見るときに便
利です。

View>Simulator Trace を選択します。シミュレータ・トレースでは、各サイクルでの
タイムスタンプやファイルレジスタにリードやライトされたデータなどの情報を見
ることができます。

Note: ブレークポイントを設定した行が実行されない場合はDebugger>Haltな
どを使って停止するまで実行し続けます。



MPLAB® IDE v6.xx Quick Start

DS51281B_J-page 16  2002 Microchip Technology Inc.

FIGURE 19: SIMULATOR TRACE DISPLAY

一番左の縦列からプログラムカウンタのアドレス (Addr)、命令のマシン語 (Op)、ラ
ベル (Label)、逆アセンブルされた命令 (Disassembly) が表示されます。その右側に
はファイルレジスタにリードやライトされたデータが表示されます :
• SA -  Source Address, リードされたレジスタのアドレス

• SD -  Source Data, レジスタからリードされたデータ

• DA -  Destination Address, ライトされるレジスタのアドレス

• DD -  Destination Data, レジスタへライトするデータ

ファイルレジスタをアクセスしない命令ではダッシュ (-) になります。

一番右の縦列はタイムスタンプです。実行時間を見ることができます。実行時間
は Debugger>Settings ダイアログの Clock パネルで入力したクロック周波数で計算
しています。
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各項目名を表示している横列の上にカーソルを置いて、右クリックするとポップ
アップメニューが現れます。

FIGURE 20: SIMULATOR TRACE CONFIGURE

チェックされた項目はトレースウィンドウに表示されます。チェックを外すと表示
されなくなります。一番下に 7Probe とか 6Probe などと表示されている項目はシ
ミュレータでは使えません (MPLAB ICE 2000 エミュレータの機能です )。
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次に何を行う ?
MPLAB IDE のヘルプメニューにはシミュレータのオンライン・チュートリアルがあ
ります。MPLAB IDE 関連のドキュメントや MPLAB IDE のオンライン・ヘルプでも
いろいろな機能について説明しているので参照してください。そのなかでいくつか
の機能について説明します。

デバイスに書き込み

デバッグが終わったら、デバイスにコードを書き込みます。次のライタのどれかと
PIC18F452 デバイスを持っていれば、デバイスにコードを書き込めます :
• MPLAB ICD 2
• PICSTART Plus 開発用プログラマー ( ファームウエアは v3.00 以降 )
• PRO MATE II デバイス・プログラマー

次のようにライタを選択して使う準備をします :
1. Programmer>Select Programmer を選択してライタを選びます。Programmer

メニューの項目が変わり、ツールバーにアイコンが追加されます。

2. パソコンとの接続を開始します。PICSTART Plus か PRO MATE II の場合は Pro-
grammer>Enable Programmer、MPLAB ICD 2 の場合は Programmer>Connect
を選択します。

3. Programmer>Settings ダイアログを使ってライタの設定をします。今回はデ
フォルトの設定のまま使います。

FIGURE 21: PRO MATE II SETTINGS DIALOG
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4. コンフィグレーションビットを設定します。今回はデフォルトのままで構いま
せん。ソースコード上にコンフィグレーションビットの設定を記述することも
できます ( 推奨 )。また、Configure>Configuration Bits を選択して Configura-
tion Bits ウィンドウで手動で設定することもできます。

5. MPLAB IDE にロードされている情報をデバイスに書き込むには Program-
mer>Program を選択します。 処理状態はステータスバーに示されます。処理結
果は Output ウィンドウの PRO MATE パネルに次のように表示されます。

PRO MATE Error Log File

Programming

31-May-2002. 13:06:19
Device Type: PIC18F452

Programming/Verification Successful!

書き込みするときには自動的にベリファイも行います。Programmer>Verify を選択
すれば、再度ベリファイを行えます。

シミュレータのオプション

MPLAB IDE のダイアログでは、シミュレータの設定がほかにもあります。

コンフィグレーションビットの設定

ウォッチドッグタイマ (WDT) はデフォルトではイネーブルになっています。WDT
がタイムアウトするとシミュレータでもリセットします。

• Configure>Configuration Bits を選択します。

• ウォッチドッグタイマの設定の Enabled のところをクリックすれば、選択メ
ニューが表示されます。Disabled にすれば WDT ではリセットしなくなります。

FIGURE 22: DISABLE THE WATCHDOG TIMER

TIP: ソースコード上でコンフィグレーションビットの設定を記述すれば、デ
バッガの動作に反映します。たとえばソースコードでオシレータの設定
を記述すれば、デバッガはそのオシレータの設定を使います。
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シミュレータの設定

Debugger>Settingsを選択してデバッガ(ここではMPLAB SIMシミュレータ)の設定を
行うダイアログを表示します。

Clock パネルでシミュレータのクロック周波数を設定します。ここでの設定はストッ
プウォッチやトレースで実行時間を計算するために使われます。

FIGURE 23: DEBUGGER SETTINGS: CLOCK

Break Options パネルではブレークポイントの設定ができます。Global Break Enable
のチェックを外すと、ブレークポイントは無効になります。これは多数のブレーク
ポイントを設定している場合に、全ブレークポイントを無効にする場合に便利です。
Global Break Enable を再度チェックすればブレークポイントを有効にできます。

FIGURE 24: DEBUGGER SETTINGS: BREAK OPTIONS
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Limitations パネルではシミュレータとデバイスとの相違点を表示します。このパネル
では一般的な相違点を表示しています。

FIGURE 25: SIMULATOR SETTINGS: LIMITATIONS

Details ボタンをクリックすると、 詳細な相違点が表示されます。一般的な相違点も
表示できます。

FIGURE 26: SIMULATOR SETTINGS: LIMITATIONS
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MPLAB ICD 2
この章では v6.00 から v6.10 にバージョンアップしたときに変更があったダイアロ
グについて、いくつか説明します。また、MPLAB ICD 2 については MPLAB ICD 2 
Quick Start Guide (DS51268) も参照してください .
MPLAB ICD 2 のドキュメントで推奨されているように電源を接続して、MPLAB ICD 
2 をパソコンに接続します。ICD はデバッガかライタとして選択できます。

デバッガとして選択するには Debugger>Select Tool>MPLAB ICD 2.
ライタとして選択するには Programmer>Select Programmer> MPLAB ICD 2. 

MPLAB ICD 2 の通信設定

Debugger>Settings の Communication パネルで通信設定ができます。

FIGURE 27: MPLAB ICD COMMUNICATIONS SETTINGS

Note: MPLAB ICD 2 をデバッガとライタの両方では選択しないでください。
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MPLAB ICD 2 オペレーティングシステムの更新

MPLAB ICD 2 をはじめて使うときや MPLAB IDE が更新されたときは、MPLAB ICD 2
の README ファイルでファームウエアが更新されたかを確認してください。バー
ジョンが正しくないと、正しく動作しないことがあります。

更新されたファームウエアは Debugger>Download ICD 2 Operating System か Pro-
grammer>Download ICD 2 Operating System でインストールできます。

ダウンロードの実行結果が Output ウィンドウに表示されます。エラーが発生した
ら、電源やケーブルを確認して再度ダウンロードしてください。問題解決には
MPLAB ICD 2 のオンラインヘルプも参照してください。

FIGURE 28: MPLAB ICD 2 OUTPUT WINDOW

MPLAB ICD 2 の書き込みオプション

Settings ダイアログの Program パネルで書き込みの設定ができます。

FIGURE 29: MPLAB ICD 2 PROGRAM SETTINGS

MPLAB ICD 2 をデバッガとして選択しているときは、Program パネルの Configura-
tion は常にチェックされます。これはインサーキットデバッグ機能をイネーブルにす
るためです。

MPLAB ICD 2 をライタとして選択しているときはチェックを外せます。
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図のように End プログラムアドレスを下位アドレスに設定すれば、書き込みが早く
終わります。 Full Range ボタンで全プログラムメモリに書き込みを行う設定にでき
ます。

MPLAB ICD 2 で使うメモリ領域

MPLAB ICD 2 を使うと MPLAB IDE のいくつかのメモリ・ウィンドウは変わります。
RRやRRRRと表示された箇所はMPLAB ICD 2がデバッガの場合に使う領域であるこ
とを示しています。

FIGURE 30: MPLAB ICD 2 RESERVED PROGRAM MEMORY AREAS

MPLAB IDE のオンラインヘルプ

MPLAB IDEにはオンラインヘルプがあります。 もし MPLAB IDE について知りたいこ
とがあれば、オンラインヘルプを参照してください。選択しているデバイスによっ
て、オンラインヘルプの項目が変わります。特に新しいデバイスとツールの組み合
わせで使う場合などではオンラインヘルプを参照してください。

FIGURE 31: MPLAB IDE HELP MENU
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MPLAB IDEのヘルプはMPLAB IDEやほかのマイクロチップの開発ツールのすべてに
ついて説明しています。また、Microchip Update Notification system というサービス
もあります。

FIGURE 32: MPLAB IDE HELP DIALOG

ワークスペースとプロジェクト

MPLAB にはワークスペースとプロジェクトがあります。

MPLAB のワークスペースは MPLAB IDE ウィンドウのディスクトップ領域のことで
す。 ワークスペースは開いているウィンドウ、選択した PICmicro デバイス、使用し
ているデバッガやライタ、ハードウエアのツールの接続方法を覚えています。ふつ
うワークスペースはプロジェクトを使う前に設定します。

プロジェクトは、MPLAB のワークスペースのなかで開くもので、ソースコードやビ
ルドする方法やビルドするために使ったツールなどの情報を含みます。プロジェク
トは違うフォルダや違うパソコンに持ち運びができますが、ワークスペースは持ち
運びはできません。

ワークスペースには複数のプロジェクトを入れることができますが、MPLAB IDE は
同時には一つのワークスペースしか開けません。
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Configure>Settings メニューでワークスペースの設定ができます。本書のような使い
方をする場合は設定を変える必要はありません。

FIGURE 33: SETTINGS MENU SELECTION

Workspace というパネルがあります。

FIGURE 34: SETTINGS: WORKSPACE TAB

Configure>Settings ダイアログの Workspace パネルでは次の設定を行えます :
• MPLAB IDE を実行開始したときに最後に使っていたワークスペースを開く。一
つのプロジェクトを継続して使う場合に便利です。

• エミュレータやシミュレータを使用開始する前に全テキストファイルを保存す
る。これは、ソースファイルなどを変更した後、デバッグを行う前にコンパイル
し忘れるのを防ぐための機能です。

• HEXファイルを読み込む前にブレークポイントを外す。 変更が少ない場合でHEX
ファイルをロードする場合のために、ブレークポイントを外さないようにもでき
るようになっています。.

Note: HEX ファイルを読み込むのは、おもにコンパイルしたコードをデバイス
に書き込むためです。ビルドするたびごとに HEX ファイルは生成され
ます。



 2002 Microchip Technology Inc. DS51281B_J-page 27

MPLAB® IDE v6.xx Quick Start

Program Loading パネルで、更新されたコードがロードされる場合に初期化するメモ
リ領域を選択できます。

FIGURE 35: SETTINGS: PROGRAM LOADING TAB

Configure>Settings ダイアログの Projects パネルで、プロジェクトをビルドするとき
の動作をカスタマイズできます。

FIGURE 36: SETTINGS: PROJECTS TAB
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このパネルはプロジェクトの設定を行えます。デフォルトのまま使うことを推奨し
ます。不用意にチェックを外すと編集したものがなくなる場合もあるので注意して
ください。一番下の Use one-to-one project-workplace model という項目では
MPLAB IDE のプロジェクトの扱いかたを選べます。チェックするとワークスペース
は一つのプロジェクトしか持てないようになり、使用上はワークスペースとプロ
ジェクトは同じになります。  

Note: チェックを外すと、ワークスペースは複数のプロジェクトを持てるよう
になります。これはメモリブロックごとに違うコードをコンパイルする
ような用途の場合に便利です。たとえばブートローダーとアプリケー
ション部を持つことができます。ブートローダーはアプリケーション部
と独立していて、コードのダウンロードや更新を行います。同時には一
つのプロジェクトしか使えません。複数のプロジェクトを持つワークス
ペースで、プロジェクトを選ぶには Project ウィンドウのなかでそのプ
ロジェクトの上にカーソルを置き、右クリックします。
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NOTES:


